mpeg4ip-1.5.0.1을 ubuntu 12.04에서 컴파일 하기 1

Linux에서 AirVideo를 설정하기 위한 방법이 적힌 블로그를 보면서 따라고 하고 있었는데, mpeg4ip가 의도대로 컴파일 되지 않는 곳에서 막혀 버리고 말았다. 여기저기 찾아 보니 예전 버전의 gcc/g++에서는 잘 됐던것 같은데 최신 버전으로 판올림이 되면서 컴파일 되지 않게 된것 같다. hardy를 소스트리에 넣고 gcc-4.1 설치를 시도 했더니 오류가 뜨면서 동작하지 않았다. 결국, 4.4버전에서 mpeg4ip-1.5.0.1을 빌드되도록 고치기로 했다.

*주의: 이 포스트이 내용은 단순히 mpeg4ip-1.5.0.1을 gcc/g++ 4.4버전에서 빌드 되도록 수정하는 것에 관한것 이다.

다음 두개의 패치 파일을 다운로드 받아 적용하면 되며, 적용 순서는 다음과 같다.

패치 내용에 대한 보다 자세한 설명은 “mpeg4ip-1.5.0.1을 ubuntu 12.04에서 컴파일 하기 2“를 참조.

Enjoy!

20120617-100128.jpg

 

댓글 남기기

이메일은 공개되지 않습니다. 필수 입력창은 * 로 표시되어 있습니다